Omega Owners Forum
https://oldsite.omegaowners.com/forum/YaBB.pl
Omega Help >> Omega Electrical and Audio Help >> ripspeed DV720 not turn off?
https://oldsite.omegaowners.com/forum/YaBB.pl?num=1316226095

Message started by freecall666 on 17. Sep 2011 at 03:21

Title: ripspeed DV720 not turn off?
Post by freecall666 on 17. Sep 2011 at 03:21
dose any one know why the unit will not turn off,,, just says bye bye. and stays on ever thing eles is ok blinks for mo as going to turn off then comes back on and dose 2beeps???? thanks if any one know? works good apart from that...

Title: Re: ripspeed DV720 not turn off?
Post by Lincs Robert on 17. Sep 2011 at 07:57
Is this for the Omega Rusty?

Won't it cover up all the switches when it's out?

Isn't there something about Vauxhall swapping live and switched power over, could that have something to do with it?

Has it got a remote power on facility? If so then I'd look there first.

Title: Re: ripspeed DV720 not turn off?
Post by Darth Loo-knee on 17. Sep 2011 at 08:45
You maybe better posting this thread in the Electrical Section mate.

Daz :y

Title: Re: ripspeed DV720 not turn off?
Post by tmx on 17. Sep 2011 at 18:08
check ignition switch wiring the red and yellow wires on the radio end itll be in the head units insructions about reversing them if its not ill find you a Youtube vid you ca watch that explains it

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 17. Sep 2011 at 18:55

tmx wrote on 17. Sep 2011 at 18:08:
check ignition switch wiring the red and yellow wires on the radio end itll be in the head units insructions about reversing them if its not ill find you a Youtube vid you ca watch that explains it

its been working in car for year with no problems. just wondering if and were the micro switch is, it maybe that. failing that get another board off bay.. nothing is burnt out on board, and thats the only problem with it only noticed it when went out and battery flat only had 6volts left in battery.

Title: Re: ripspeed DV720 not turn off?
Post by r1 on 17. Sep 2011 at 20:31
cant you just take the face off?

Title: Re: ripspeed DV720 not turn off?
Post by Jimbob on 17. Sep 2011 at 20:36
This Topic was moved here from General Car Chat by Jimbob.

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 18. Sep 2011 at 05:17

r1 wrote on 17. Sep 2011 at 20:31:
cant you just take the face off?

dont know what you mean fixed front.. think its says some were that pieoner make the boards for them but dont know model name is.

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 18. Sep 2011 at 11:39
its ok just won one off bay under 40 with out audio out put problem so just going to swap audio chip with mine so should be fixed soon.. :y

Title: Re: ripspeed DV720 not turn off?
Post by Lincs Robert on 18. Sep 2011 at 16:45
Wont the chip be soldered in place?

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 18. Sep 2011 at 19:35

Lincs Robert wrote on 18. Sep 2011 at 16:45:
Wont the chip be soldered in place?

yeah but can remove it, easy job to remove. its not a micro chip, plus the one got may not even be the chip may just be the fuse for the amp on  the board there is 2 fuses for the amp on board.

Title: Re: ripspeed DV720 not turn off?
Post by VXL V6 on 18. Sep 2011 at 19:45
Might be able to fix the power problem on the first one, I imagine the unit has got damp and the contacts on the microswitch for the screen closed position are rusty.

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 18. Sep 2011 at 20:25
no switch is fine, and screen is fine. somthing has crossed over so cotinous volts and ignition and shutdown are all stuck on. and damp shield is fine....... had unit down to bare bones just board and front pannel. then just board and fan still on so still power being on.

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 20. Sep 2011 at 18:19
right some good news and some bad news just found what is wrong just had friend e-mail me the board diagram and it would be a single chip that dose the lot. chip numberTDA7388. not only dose the sound dose standby- mute- sound- sound quality low. and some other stuff. so if you have this model with a fault as mentioned above then there is the bad boy. so will have 2 players soon as just got parts for both for 18-p&p so if want one after give me pm.. :y

Title: Re: ripspeed DV720 not turn off?
Post by Kevin Wood on 21. Sep 2011 at 10:54
The TDA7388 is just an audio power amplifier and nothing more. Can't see how it would prevent the head unit from powering down so I wouldn't be too hasty in ordering one, TBH. :-/

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 21. Sep 2011 at 12:26
well tuck chip out and tryed it it powers down now with out the chip, somting wrong with chip dose not match info for chip stand bye go's straight to power and vcc, would say its has over heated, also fan power gose straight to power aswell. could not get original chip as says they are faulty, also the power out put of the chip to standy should be 3.3volts but coming out is 5.8volts witch is just over its max.

Title: Re: ripspeed DV720 not turn off?
Post by freecall666 on 22. Sep 2011 at 13:39
got one fixed now, one come in post has dif fault than was on add, will not turn on at all so need a good look at it.. :y

Omega Owners Forum » Powered by YaBB 2.5 AE!
YaBB Forum Software © 2000-2010. All Rights Reserved.