This is the old site. Please use the new site.

  Welcome, Guest. Please Login
Omega Owners Forum
 
  Home Shop Help Search Members Login  
 

This is the old site. Please use the new site.

www.omegaowners.com/forum/index.php.

 
Page Index Toggle Pages: 1
Send Topic Print
Car not starting? (Read 3122 times)
D
Newbie
*
Offline



Posts: 20

Drives: 2.2 Sport
Car not starting?
22. Sep 2011 at 20:24
 
My miggy has been parked out in the street for the last 2 weeks or so as I have been away on holiday/busy with work on returning etc. Got near the car and immediately realised there was a problem as the remote wouldnt unlock the door. So manually unlocked it and the alarm didnt go off. Then tried starting the car and all I got was the alarm button with the little mans image blinking and weak lights on the dash. Then as I tried starting it for the 3rd time the alarm went off and I just about manged to stop it with the keyfob. Then came this ticking noise from around the passenger side dashboard area. eventually a friend came along we used jumped leads and the car started with the alarm going off again for a few seconds and then stoppin of its own accord (not responding to the keyfob). Since then the battery's been fine and have had no immediate problems with starting or the alarm. Now as the car lives on the road I am not sure what has happened with regards to the alarm since I have left it there this afternoon.

My thoughts - could it be a faulty power sounder thats drained the battery or a weak battery thats upsetting the powersounder? I suppose checking the battery and alternator would answer some of these questions. But is there any other way of checking which is at fault or am I missing something else?

Should I be removing the power sounder? What is its function normally? would I loose any functionality as a result of removing it.
Back to top
 
 
IP Logged
 
freecall666
Senior Member
****
Offline


fun for all, get with
the program

Posts: 656
looking over your shoulder
Gender: male

Drives: 2.0I polar sea blue
Re: Car not starting?
Reply #1 - 23. Sep 2011 at 02:12
 
you can just unplug the power sounder, the horn next to it should still work with the alarm, but would check to see if it still works. give the battery a good charge and see how the power drian go's. if not got tools some one on here near to you may be able to help. post area you in.
Back to top
 

doit your self (DIY)
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print

This is the old site. Please use the new site.